Skip to content Skip to navigation

Globus Toolkit Support Changes

Jun 28, 2017

On May 26, 2017 the Globus team announced that “Support for open source Globus Toolkit will end as of January 2018; The Globus cloud service and Globus Connect are unaffected”:

https://github.com/globus/globus-toolkit/blob/globus_6_branch/support-changes.md

This announcement does not affect XSEDE’s use of Globus file transfer and sharing cloud service (SaaS), Globus Auth identity and access management service, or the Globus Connect products.  At the end of 2018 Globus will discontinue maintenance and security patches for these XSEDE components: GridFTP server from source or RPM, GSI-OpenSSH, MyProxy, Globus Toolkit client (includes globus-url-copy), and GRAM5.

Over the coming months the XSEDE Cyberinfrastructure Integration (XCI) team, in coordination with other XSEDE teams, the Globus team, and external national and international cyber-infrastructure providers and collaborators will explore the full impact of this change and prepare plans to maintain important functionality.

We invite XSEDE staff and the XSEDE community to send related requirements and questions by August 2017 to help@xsede.org using the “Subject: Globus Toolkit Support Changes”. To participate in online Q&A forum discussion on this topic please visit:

https://software.xsede.org/xci-127-qa

Thanks,

-- The XSEDE Cyberinfrastructure Integration (XCI) Team