XCI-826 Testing Discussions

10 posts / 0 new
Last post
XCI-826 Testing Discussions
Delivery Effort Stage: 

This is feedback from the chapter 1 of the Installation Guide’ (XSEDE Globus Connect Server v5.4)’.

I’ve never done this, so I get them by just reading it at this point.

  • For the ‘Installation Guide’ (XSEDE Globus Connect Server v5.4) , there is “...using the globus-connect-server54 installation…” phrase in the very first section.  Is the “globus-connect-server54” correct?   (54 or 5.4 or none?)
  •  
  •  For the ‘Installation Guide’ (XSEDE Globus Connect Server v5.4) , about the 1.a, it seems suddenly appeared without an anchor point from the installation doc. It would be helpful to point it if applicable like 1.b did with “.. In Section “4.2.2. Setup the Endpoint ..”.
  •  
  •  For the ‘Installation Guide’ (XSEDE Globus Connect Server v5.4), about the 1.d and 1.e, I was wondering if this has an anchor point or is this after a certain step?   If applicable, it would be helpful to point to it or comment on it.

This is feedback from the chapter 2 of the ‘Installation Guide’ (XSEDE Globus Connect Server v5.4)

  • At the beginning of chapter 2, right after the dotted lines, there is a phrase “Refer to the Design for XSEDE SP Deployment of Globus Connect Server 5.4 for a more in-depth…” .  When I clicked the link, it led to the “5.1.2.1 Primary access - For members of XSEDE-allocated projects“ section of another doc (Design for XSEDE SP Deployment of Globus Connect Server 5.4) .   For sometime, I got confused when I was scrolling down from the 5.1.2.1 section.    It would be better to show contents from the 5.1.2  section.  As I am reading, I was wondering about the term “collection” and it turned out that it was under the 5.1.2 section of the other doc.   I also found the term “storage gateway” which is good to understand ahead. 
  •  
  • At the beginning of Chapter 2, right before 2.3.1 , there is a phrase “The configuration of a storage gateway and mapped collection for Science Gateways is very similar to that from Option 1 ... “.   It made me wonder what is the ‘Option 1’.  Does it mean option at 2.2 or the previous option (guest collection) ? Probably good to update the word.

This is a question.

In the Globus Connect Server v5.4 - Integrated Testing Plan doc ( https://docs.google.com/document/d/1YaqxkS-AtIin0VYl5Pt_OkHW5LJJw1SLqbmg... ) , at the "Testing Setup" section, I see the "/local/xsede-*-storage/*" paths are listed. However, I don't have access permission to the "/local/" path.
Is this fine to proceed or do I need access permission to those paths?

I just fixed the permissions so that you have access to these two paths that you do need:

[jkm@xcidev1 ~]$ ls -l /local/xsede-projects-storage/
total 0
drwxr-x---. 2 jkm users 29 Apr  7 13:37 jkm
[jkm@xcidev1 ~]$ ls -l /local/xsede-guestdata-storage/
total 0
drwxr-s---. 2 jkm guestdata 29 Apr  7 14:40 jkm

In the 'https://docs.globus.org/globus-connect-server/v5/#install_section' , at 4.2.1-6 , I got stuck because I don't know what to enter for the 'Client Secrets' Description field.   I think it would be helpful to tell a user what to enter for it in our 'XSEDE Globus Connect Server v5.4 Installation Guide' doc in the '1. Creating an Endpoint' section after a.  
What should I enter for it?  Where do I get it?

I tried empty or a string, I get an error message "Failed to get client secret. Please try again."

https://docs.globus.org/globus-connect-server/v5/#create_service_credent...

explains how to obtain the client secret in section 4.2.1. When you follow those instructions the developers.globus.org application displays a "Generate New Client Secret" button that you press.

 

Yeah, I followed the steps and getting the error at #6 step at 4.2.1 section on the doc. 

Since I can’t attach pictures, I just sent the related email to you.

I logged out and logged back to globus.org and tried again, and it worked this time!

It must have been a system hiccup.  I did exactly the same and I get the Client Secret ID this time.  No idea.

Anyway, if you care about a new user's confusion, I think it's still helpful to mention that the 'Description' can be any string.  If I knew that, I probably would have tried again without getting stuck on such a strange hiccup.  

 

This is just to record my procedure here. ( only the steps that are not totally clear to me if it's a step must do or an optional step. )  

 

  • At the "4.5. Log into the endpoint" , it looks like an optional step.  I ran the command, went to the link and enter the "Native App Authorization Code" from the web link.  The command displayed "You have successfully logged into GCS endpoint ...".  Not sure what to do after that, so record it here.

 

  • At the "4.7. Set the endpoint as managed", I ran the command but got an error.   Thus, I requested adding the endpoint ID to the XSEDE Globus subscription via help@xsede.org according to step '1.d' in "XSEDE Globus Connect Server v5.4 Installation Guide".  (this is just testing so a little confused )

 

Log in to post comments