Skip to content Skip to navigation

python-amqp >= 1.4 requirement on Centos/RHEL 6

2 posts / 0 new
Last post
python-amqp >= 1.4 requirement on Centos/RHEL 6

Minor issue on the yum installation method for IPF 1.4-rc2.   There is a dependency on python-amqp >= 1.4.   The latest available version of this python module on EPEL for RHEL 6 is 1.3.3-1.   Installers will need to get it from another repo or rebuild it from a newer source rpm. 


root@racd:~\[root@racd ~]#  yum install ipf-xsede
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ipf-xsede.noarch 0:1.4-rc2 will be installed
--> Processing Dependency: python-amqp >= 1.4 for package: ipf-xsede-1.4-rc2.noarch
--> Finished Dependency Resolution
Error: Package: ipf-xsede-1.4-rc2.noarch (XSEDE-Development)
           Requires: python-amqp >= 1.4
           Installed: python-amqp-1.3.3-1.el6.noarch (@epel)
               python-amqp = 1.3.3-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I think the easiest thing to do is actually for me to build a python-amqp 1.4.3 rpm and put it in our XSEDE repos.

I had thought, actually, that I had already done this, but it doesn't appear that it ever got put in the development repos.

Log in to post comments